Ivanovo Linux Users Group - Not logged in
Forum Help Search Login
Previous Next Up Topic Софт / Программное обеспечение / devede. ошибка сегментации (18867 hits)
- By anonymous13 Date 22.08.08 21:08 Edited 22.08.08 21:13
Решил установить эту программу на мопс6.1 (слака12), скачал исходники и слакбилд, потребовались еще и libcdio и vcdimager, их тоже скачал и слакбилды к ним, скомпилил.
Программа запускается, но выводит:
DeVeDe 3.10
Locale: ru_RU.UTF-8
Using package-installed files
(devede:10072): libglade-WARNING **: unknown property `has_tooltip' for class `GtkCheckButton'
(devede:10072): libglade-WARNING **: unknown property `program_name' for class `GtkAboutDialog'

но работает, пока не нажмеш одну из кнопок, тогда и выходит "ошибка сегментации".
Как можно бороться с такими проблемами? Может вылетает не сама программа а одна из зависимых?

;-) правда при компиляции devede 3.10 слакбилд был от версии 3.4 , может в этом корень?
Вы ещё работаете на MS Виндовз ? А мы уже работаем на себя. :-)
Parent - By LOE (Site/forum admin) Date 22.08.08 21:11
Скорее всего, у тебя libglade не той версии.
Почитай внимательно требования к версиям используемых библиотек.
Или обновляй/откатывайся в версиях, или используй другую версию (новее или старее) devede.
"No! Try not! Do. Or do not. There is no try." -- Yoda
Parent - By anonymous13 Date 22.08.08 21:36
libglade-2.6.1-1
Ридми в слакбилде, о версиях требуемых зависимостей ничего не сказано (
в исходниках devede есть devede.glade, там:
<!DOCTYPE glade-interface SYSTEM "glade-2.0.dtd"> 
как я понимаю, треба версия выше 2....

А может есть какие то средства более точно узнать причину вылета программы? (например dtrace какой-нибудь)
Вы ещё работаете на MS Виндовз ? А мы уже работаем на себя. :-)
Parent - By LOE (Site/forum admin) Date 22.08.08 21:42
Если для сборки есть configure, то он он при проверке наличия библиотек выводит минимально необходимую версию.
Внимательно посмотри лог и проверь соответствие.
Бывает версия не соответствует в третьей цифре, но это оказывается фатальным для программы.

Для трассировки используй strace (читай опции запуска - помогут, особенно -o )

PS. переношу топик в общие. Не думаю, что это так уж сильно специфично для слаквари.
"No! Try not! Do. Or do not. There is no try." -- Yoda
Parent By anonymous13 Date 22.08.08 22:53
Если для сборки есть configure
упс..программа на питоне...есть только install.sh
Вы ещё работаете на MS Виндовз ? А мы уже работаем на себя. :-)
Parent - By anonymous13 Date 22.08.08 22:07
нашел версию 3.9 и слабилд к ней
качаю...
Вы ещё работаете на MS Виндовз ? А мы уже работаем на себя. :-)
Parent By anonymous13 Date 22.08.08 22:52
версия 3.9 заработала...((( эх...
Вы ещё работаете на MS Виндовз ? А мы уже работаем на себя. :-)
Parent - By LOE (Site/forum admin) Date 23.08.08 20:24
Остался один вопрос: зачем самому собирать пакет, если есть репозиторий готовых? ;-)
Посмотри: http://repository.slacky.eu/slackware-12.1/multimedia/devede/3.10/
А в файле http://repository.slacky.eu/slackware-12.1/multimedia/devede/3.10/src/slack-required прописано то, что требуется для работы.
Ну а "повыше" - тьма других пакетиков ;-)
"No! Try not! Do. Or do not. There is no try." -- Yoda
Parent - By anonymous13 Date 24.08.08 21:40 Edited 24.08.08 21:46
хм...:-) "изучаю" слакбилды :-)
этот репозитарий уже прописал в mpkg... я так понимаю это основной репозитарий для слаки, которым все пользуются..да?

А в файле http:// ....прописано то, что требуется для работы.
ооо... то чего мне не хватало...  спасиб!

зы: мопс6.1
  $cat /etc/slackware-version
Slackware 12.0.0

а на http: / / repository.slacky.eu/slackware-12.0/multimedia/devede/ только версия 3.6 (((

и почему то в ...devede/3.10/src/slack-required:
"dvdauthor >= 0.6.14-i486-1sl
mplayer >= 1.0rc2-i686-1sl
python >= 2.5.2-i486-2_slack12.1"
нет потребовались еще и libcdio и vcdimager ... видимо эти от дивидиавтора...
вообщем тема разрешения зависимостей в слаке - отдельная тема )))
Вы ещё работаете на MS Виндовз ? А мы уже работаем на себя. :-)
Parent - By LOE (Site/forum admin) Date 25.08.08 21:25
Да, автоматической разборки зависимостей в слаке нет.
Хотя, есть универсальный пакетный мэнеджер (не помню как звать), который вроде как должен разрулить зависимости. Но не уверен.
А мопс 6.1 последний? Или ты не обновляешься?
Я вот стараюсь постоянно сидеть на slackware-current. Глюков на моей памяти было 1-2 штуки - когда пакет начинал как-то глючить, но (как правило) буквально на следующий день было очередное обновление.
Сейчас обновляться постоянно нет времени (да и влом), поэтому жду некоторое время и уже после этого обновляю пакеты.
Хотя самое дерево пакетов всегда стараюсь обновлять по первой возможности.

PS. кто знает, где можно достать 8-ми гиговые болванки? особенно (если вообще существуют) RW
Моя сборка-солянка перевалила за 6 Гиг и обычного DVD уже не хватает ;-)
Отвечать на PS просьба в личку дабы не засорять топик (или организовать топик в talks)

PPS. кстати, хочу попробовать BlueWhite дистр (64-х битный) на следующей неделе. В отличии от slamd64 обновляется гораздо оперативнее (практически в ногу с слакой). будут новости - доложу.
"No! Try not! Do. Or do not. There is no try." -- Yoda
Parent By anonymous13 Date 26.08.08 20:44
Мопс 6.1 последний, он основан на 12.0 слаке.
Имеет свой пакетный менеджер и использует свой репозитарий, свои пакеты tgz, в которые добавляется инфа о зависимостях в xml формате. Можно использовать и другие репы, но уже без разбора зависимостей. Плохо то, что пока в mopspackages.org маловато пакетов ((( Вот и пытаюсь из исходников проги ставить, да ищу слаковские репозитарии. .... вообщем весело :-)
Вы ещё работаете на MS Виндовз ? А мы уже работаем на себя. :-)
Previous Next Up Topic Софт / Программное обеспечение / devede. ошибка сегментации (18867 hits)

Powered by mwForum 2.12.0 © 1999-2007 Markus Wichitill

Page created in 0.075s with 10 database queries.