Ivanovo Linux Users Group - Not logged in
Forum Help Search Login
Previous Next Up Topic Дистрибутивы / Red Hat / Fedora Project / Конфликты пакетов rpm (7347 hits)
- By elijah Date 01.09.06 03:03
У меня еще один вопрос: я тут устанавливал пакеты rpm, потом удалял. И внекоторых случаях? когда хотел установить аналогичный пакет, только поновее, выводится сообщение: данный пакет конфликтует с такими-то файлами (перечисляются файлы) из такого-то пакета. Когда набираю rpm -e пакет, с которым конфликтует новый? еще не установленный пакет, выводится сообщение, что такой пакет не установлен (и правильно, он уже удален). Та же фишка происходит? когда я механически удаляю конфликтующие файлы с диска. Новый пакет все равно не устанавливается. Мне кажется, что переустанавливать Линух - не наш путь. Надо что-то делать. Но что? В Линухе я не силен...

Спасибо
Если тебе не нравится существующая культура, создай свою
Parent By Green_aciD Date 04.09.06 14:35
Есть такая интересная штука, которая называется зависимости пакетов. Суть идеи в том, что для установки какого либо пакета зачастую приходится установить дополнительный пакет (и не один!, очень часто необходимые для ее работы библиотеки). Так вот, при обновлении пакета нужно обновить и соответствующие зависимые пакеты (а от версии к версии дистра и glibc и пр.).
Заметь, что иногда имена пакетов могут быть разными (типа 0.9.4-4.lvn5) и иногда запрос через rpm может ничего не вернуть, если говорит что пакета нет, но есть сомнения, то ищи пакет сам и смотри его полное имя, а потом уже смело удаляй вместе с его зависимостями.
И не удаляй файло вручную, это плохой тон.
Previous Next Up Topic Дистрибутивы / Red Hat / Fedora Project / Конфликты пакетов rpm (7347 hits)

Powered by mwForum 2.12.0 © 1999-2007 Markus Wichitill

Page created in 0.073s with 11 database queries.